Commit 37c2bc1b authored by Chris Smith's avatar Chris Smith
Browse files

Tests for readthedocs -- take 9

Trying seperate install_requires for readthedocs environment
parent 43f49039
......@@ -20,7 +20,7 @@ import sys
import mock
MOCK_MODULES = ['numpy', 'scipy', 'matplotlib', 'matplotlib.pyplot',
'scipy.misc', 'scipy.special', 'PyQt5', 'h5py','mpl_toolkits',
'scipy.misc', 'scipy.special', 'PyQt5', 'h5py', 'mpl_toolkits',
'mpl_toolkits.axes_grid1', 'scipy.optimize',
'scipy.spatial', 'scipy.signal', 'scipy.cluster',
'scipy.cluster.hierarchy', 'scipy.spatial.distance',
......
from codecs import open
from os import path
import os
on_rtd = os.environ.get('READTHEDOCS') == 'True'
from setuptools import setup, find_packages
here = path.abspath(path.dirname(__file__))
with open(path.join(here, 'README.rst')) as f:
here = os.path.abspath(os.path.dirname(__file__))
with open(os.path.join(here, 'README.rst')) as f:
long_description = f.read()
if on_rtd:
requirements = ['psutil', 'xlrd>=1.0.0']
else:
requirements =['numpy_groupies<=0.9.3', 'pyqtgraph>=0.10',
'h5py>=2.6.0', 'igor', 'matplotlib',
'scikit-learn>=0.17.1', 'xlrd>=1.0.0',
'psutil', 'scikit-image>=0.12.3', 'scipy>=0.17.1',
'numpy>=1.11.0']
setup(
name='pycroscopy',
version='0.0a26',
......@@ -34,11 +45,7 @@ setup(
author_email='pycroscopy@gmail.com',
# I don't remember how to do this correctly!!!. NL
install_requires=['numpy_groupies<=0.9.3', 'pyqtgraph>=0.10',
'h5py>=2.6.0', 'igor', 'matplotlib',
'scikit-learn>=0.17.1', 'xlrd>=1.0.0',
'psutil', 'scikit-image>=0.12.3', 'scipy>=0.17.1',
'numpy>=1.11.0'],
install_requires=requirements,
# package_data={'sample':['dataset_1.dat']}
test_suite='nose.collector',
tests_require='Nose',
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment