Commit 2121dcd0 authored by ssomnath's avatar ssomnath
Browse files

Trying out python 3.4 and 3.7 compatibility

parent 2c5dcc9f
......@@ -2,11 +2,15 @@ language: python
python:
- '3.6'
- '2.7'
- '3.4'
- '3.5'
- '3.7'
before_install:
- sudo apt-get update -qq
# Using pip to install instead of setup.py for now to fix numba issue.
#install: python setup.py install
dist: xenial
sudo: true
install: pip install .
script: pytest
stages:
......
......@@ -14,7 +14,9 @@ with open(os.path.join(here, 'pycroscopy/__version__.py')) as f:
requirements = ['numpy>=1.13.0',
'h5py>=2.6.0',
'scipy>=0.17.1',
'scikit-image>=0.12.3',
'scikit-image>=0.12.3;python_version<"3.4"',
'scikit-image<0.14.2;python_version=="3.4"', # Dask removed python 3.4 support that causes 2019 and newer skimage to fail
'scikit-image>=0.12.3;python_version>="3.5"',
'scikit-learn>=0.17.1',
'matplotlib>=2.0.0',
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment