add getNativeCode to the qcs accelerator, move engagement to first time execute is called

Signed-off-by: Alex McCaskey <mccaskeyaj@ornl.gov>
1 job for master in 12 minutes and 45 seconds (queued for 4 seconds)
Name Stage Failure
failed
docker run_docker_deploy Deploy
info "fsevents@2.1.3" is an optional dependency and failed compatibility check. Excluding it from installation.
error css-loader@6.3.0: The engine "node" is incompatible with this module. Expected version ">= 12.13.0". Got "12.0.0"
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
error Found incompatible module
yarn run v1.13.0
error Command "theia" not found.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
The command '/bin/sh -c yarn --cache-folder ./ycache && rm -rf ./ycache && NODE_OPTIONS="--max_old_space_size=4096" yarn theia build ; yarn theia download:plugins' returned a non-zero code: 1
ERROR: Job failed: exit status 1