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Assumptions

e The following slides assume

- the NEAMS Workbench has already been installed

« NEAMS Workbench is freely available from
https://code.ornl.gov/neams-workbench/downloads

e |Installaftion notes are at
https://code.ornl.gov/neams-workbench/downloads#install-neams-worklbench-
beta

- the Dakota code has been installed
« Dakotais freely available from https://dakota.sandia.gov/download.html
 Download and unzip/tar.gz platform install

Need assistance<e Email nwb-help@ornl.gov
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Client vs. Server definition

e ‘Server’, a.k.a. a ‘cluster’, is where compute resources are
available and jobs can be scheduled

e ‘Client’, a.k.a. a ‘local’ machine, is typically a laptop or
desktop with limited resource that can be used to Iocolly run
small jobs or submit jobs fo a remote server = .

[ ¢ Macintosh/Apple client

\\\\\\\\\\\\\\\

Linux client

Windows client

#,0AK RIDGE Typical Client-Server Topology
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Additional configurations

e Single-box — compute resource without a scheduler where jobs
are submitted across the network

ngngngngng

[ | |
AR
)

e Localhost — client is the
cluster head node with
scheduler from which jobs
are submitted locally
to the scheduler
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Dakota within the NEAMS Workbench

1.

2.
3.

%

Dakota Input:
« Autocompletion
« verification
Dakota Qutput
 results plofting
Model:
« Workbench Driver
* Preprocessing
« Template editing
« Postprocessing
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/Inpu’r Parameters

design ¢ uncertain
state
continuous ¢ discrete

Optimization
Uncertainty Quantification
Parameter Estimation

\ Sensitivity Analysis j

Workbench Driver enhanced

[ 3. Model \

simulation e surrogate ¢ multi-fidelity
nested recursions

Response Qols

objectives
constraints
residuals

A

formulation recasting

Simulation

Interface | : process j




NEAMS Workbench Linux Server Installation

1. Download/copy the Workbench-Linux.zip to the server
— Secure copy from client to server — scp Workbench-Linux.zip server:

2. Unzip the deployment — unzip Workbench-Linux.zip
3. Untar the archive — tar -xf Workbench-Linux.tar.gz

4. Verity installation via the following

1. Execute Workbench-Linux/rte/entry.sh which should result in
Python tferminal with no import errors

2. Execute Workbench-Linux/bin/sonvalidjson which should resultin a
usage message (no library load errors)

Latest Linux distribution is available from https://code.ornl.gov/neams-workbench/downloads

NOTE: be sure to use the same client and server versions. Server installations can be shared between
users as long as the administrating user executes the Workbench-Linux/rte/entry.sh to configure the
necessary Python environment

%OAK RIDGE
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https://code.ornl.gov/neams-workbench/downloads

Local and Remote Application Sefup Overview

e Local application setup requires installation of the Dakota
code on the same machine as is the NEAMS Workbench

« Remote application setup requirements
— Passwordless SSH* to remote Linux machine/cluster

— PBS-based cluster scheduler
« Remote application does support scheduler-less single-box
» Tested with Torgue/MAUI, IBM LSF, SLURM

— Initial setup step using the NEAMS Workbench SetupRemote
application*

- Remote Linux machine installation of the application and the NEAMS
Workbench

%.0AK RIDGE * See |later slide instructions
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New file... 3N

Run ConfigurOTiOns - O\/er\/iew New ORIGAMI Automator project.. (3N

Open file... #0
Open ORIGAMI Automator project... 4 3¥#0

« Application configurations are available under the Open ORIGEN concentation fe..

Open UNF-ST&DARDS time series...

File>Configurations... LT

Open continuous-energy library...
Open covariance library...
Open ORIGEN gamma data...

Recent files »

 Create application run configuration
~ Connects MOOSE-BISON, Dakota, ARC, etc. to the NEAMS Workbench o s

Save #S

* Allows creation of application variants/environments Sl o
] . Close FW
— Serial vs MPI, version 6.7 vs 6.8, etc. Close all oW
[ oK ) s Application configurations Print 3P
Moose [ Add.. Add Application Config . &
FoteatonEonmen
Configuration:  Bison1 [ Addv Remove Rename... Exit 8Q

Application Options /

Property Value ®  ® == Applications...

v Shared
Additional Argunfents - S o
Executable Ipath/to/bison-opt Select application to configure:

Output Basename

Output Diregtory IE)akota

Add or clone Application %E:::ch [
configuration environment :
" Allow Denrecated
Run Environment
Variable Values Add
Unset
%gﬁ)ﬁ%{gﬁg Apply Cancel  (OKI




Local Configuration of Dakota UQ and Optimization®

° Open The AppliCOTion [ © = Application configurations
Configuration dialog via .
File>Configurations cwon | A | Remoe
o SeleC'I' Add... Dqkoll-q Config.ura.tion: .6.8 E Addv Remove Rename...
 Update the Executable 5’°;1":£ed
itional Arguments
property’s value to be the
absolute path to dakota.sh Oupu Diectry
Or quO‘I'q.bqi' Run Environment
Variable Values Add
e A pause can be observed as Unset

the NEAMS Workbench
requests/generates the

Dakota input definition Apply Corcel | (@




Remote Run Configuration of Dakota Overview

1.

Configure passwordless SSH between the client and the server

2. Using the client install of the NEAMS Workbench, do the following:

%

a.
o.
C.

d.

h.

Enable the NEAMS Workbench's Setup_Remote application
Create the application-server Setup_Remote input

Run application-server setup remote input to generate the NEAMS
Workbench Dakota remote run configuration.

Configure the Dakota_remote

Open any Dakota input and select the Dakota remote run configuration to
activate input validation, autocompletion, syntax highlighting and job
launch capabilities

Edit input as needed

Use the Dakota remote run configuration to launch the Dakota input from
your client to the server

Wait for job to finish
Open files associated with the input file (*.out, etc.)

OAK RIDGE
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Passwordless SSH Setup
« Required for remote run configurations

o Appends client machine’s authorized public key to the user’s
list of authorized keys residing on the server. The following
statement is sufficient to do so on Linux or Mac clients:

ssh server 'cat >> .ssh/authorized keys && chmod 644 .ssh/authorized keys' < ~/.ssh/id rsa.pub

« Replace ‘server’ with the name of target server. Test the
passwordless ssh by attempting to ssh o the server. You should
NoO longer observe the need to specify a password.

o Assumes server..ssh directory exists. If this does not exist,
run ssh-keygen on the server 1o generate the SSH directory.

« On Windows clients use the CMD console program to execute

type .ssh\id rsa.pub | ssh server "cat >> .ssh/authorized keys && chmod 644 .ssh/authorized keys"

%OAK RIDGE
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Start the client install of the NEAMS Worklbench

e Execute Workbench-<OS>/bin/Workbench

e Help documentation will display during the
first starfup

e Help documentation is accessible via
Help>Help Documentation

000 = NEAMS Workbench
File Edit View Run Help

Reload Save Saveas Close Print : Cut Copy Paste : Undo Redo Find

Q06 Navigation

m
5

[ JON | #s NEAMS Workbench
| File Edit View Run [HEIBI

chIoad Save Save as About opy Paste : Undo Redo Find

(x N ) Navig  Documents

Filter
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‘Workbench 1.0.pre-b1 documentation »

Table Of Contents

NEAMS Workbench User
ocumentation
Getiing Started with
NEAMS Workbench and
a supported Appiication
Requremens
» Supported Operating

Requirements
+ Foature

Next topic

Quick search

NEAMS Workbench User Documentation
Welcome to the NEAMS Workbench user documentation.
Youare here for two reasons

1. Use NEAMS Workbench to help you use an application, which are currenty
o SCALE Code System: comprehensive modeling and simulation suite for nuciear safety analysis
and design, https://www.omi goviscale
« CSAS: Critcality Safety
= MAVRIC: Radiation Shielding
« TRITON, POLARIS: Reactor Physics
= ORIGEN: Isotope concentration, activty, and radiation source term characterization
= XSProc: Cross Section Processing
= TSUNAMI: Sensitvity and Uncertainty

o ARC: Argonne Reactor Computation, https:/www.ne.anl.govicodes, and the PyARC interface
(RS Workbench Help <nwb-helplorad.gov:)
= MC2-3: Fast Reactor Cross Section Processing Codes
« DIF3D: Diffusion and Transport Theary Codes
= REBUS: Fuel Cycle/ Depletion
= PERSENT: Perturbation Theory Solver
= PYARC: Enhanced user inerface to the above

© MOOSE Applications - http://mooseframework.org/
= Bison: A Finite Element-Based Nuclear Fuel Performance Code, htps://bison.inl.gov/
« SAM: A Modem System Analysis Tool for Advanced Nuciear Reactors,
hitps/www.ne.anl.govicodes/sam/

o Dakota - UQ and Optimization toolkt, htps/dakota.sandia gov/
 Nek5000: High-order solver for i i

2. Integrate an application into NEAMS Workbench
o Read Application Integration section
© Clickthe nelp>pocusenta training Session’.pdf
o Contact yeas workbench Kelp <rwb-helphorni.govs

Getting Started with NEAMS Workbench and a supported Application
There are several steps to integrating a supported application into NEAMS Workbench.
1. Create an application runtime configuration via Configurations
2. Open or create an application input file

o May require the selection of the application's grammar, more of which can be leamed from the
Grammar Support section.

3. Edit, navigate, validate, execute, review.
now there is room for improvement, help us prioriize by providing feedback 1o xeas
Workbench Help <awb-helpfornl.gov>

Requirements

Supported Operating Systems
+ Linux 64-bit (RHELS)
+ Mac OS X (Darwin) 10.95 or newer
+ Windows 7,10 64-bit

For help compiing NEAMS Workbench from source please email xexs woskesch telp <owb-belptorad..gov>.

System Requirements

+ Minimum requirements: 2 GB RAM, dual core processor
« Recommended requirements: 4+ GB RAM, quad core processor
+ Recommended for details models: 16 GB RAM

Features

The NEAMS Workbench application consists of multiple components rendered as several panes in a GUI on
your terminal. Some of the primary components include:

+ Document Navigator - which allows quick navigation to input blocks

+ Input Editor - which features cursor context and automatic validation

+ Interactive Geometry Viewer - which includes a Vislt GUI control panel

« Data Plots - in either tabular or graphical format

An example NEAMS Workbench display s shown below:

08 mecrediastid_cute
Fna3itas

+ Setiings
o Environment
o Filter Set




Configure the Setup Remote Application

 Click File>Configurations...

[ NON | = NEAMS Workbench
JB8) Edit View Run Help
New file... . EN y Paste Undo Redo Find
- New ORIGAMI Automator project... TN ' '
ﬁ New Visualization...
Open file... #0

Open ORIGAMI Automator project...  {+30
Open ORIGEN concentration file...
Open UNF-ST&DARDS time series...

Open multigroup library...
Open continuous-energy library...
Open covariance library...

Open ORIGEN gamma data...

Recent files >
Recent ORIGAMI Automator projects

Reload #R
Save #S
Save as... O #S
Save all

Close #EW
Close all CEBW
Print BP
Settings... 3,

Reset settings

Exit ®8Q
%OAK RIDGE I
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Configure the Setup Remote Application

e Click Add... and select Setup_remote and click OK

® 0 = Application configurations

woose [} (D "o

Application Environme

Configuration:  Bis

ARDIcStion Options Moose Add... Remove
Propenrty
v Shared . g0 ;
Additions Application Environment
Executat
8u:pu:g Configuration:  Bison 1 Add v Remove Rename... Load Grammar
utpu
Save Wc L X
S Application Options
Run Environment Property O @ == Applications...
ar v Shared
e Additional Arguments Select application to configure:
Executable
Output Basename v Arc
Output Directory Ctffuel
Save Working Directo Dakota
Timactamn g ry Halite '
Hello_world r
Apply . 1 Nekdnuc )
Run Environment } Nek5000 F
T Variab Scale
ariable Btup_remote Add
iera
%OAK RIDGE Workbench Unset
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Configure the Setup Remote Application

e Click Load Grammar, Apply, and OK. This enables
SetupRemote input creation.

® 0 == Application configurations

Setup_ren Add... Remove

Application Environment

Configuration: = Setup_remote 1 B Add v Remove Rename... —

Application Options

Property Value
v Shared
Additional Arguments
Executable
Output Basename
Output Directory

Save Working Directory [

Timactamn

Run Environment

Variable Values Add

Unset

Apply Cancel OK
%OAK RIDGE
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Create the remote Dakota Setup file

e This connects the client/local NEAMS Workbench
to the remote NEAMS Workbench and Dakota
installation

o New file

Save As: dakota_remote.setup

1. Click File>New file...

2. Provide file name of
dakota_remote.setup
and select Setup_remote
as the file type.

3. Click Save

Name Date Modified

Files of type: Setup_remote - Setup_remote 1 file... H

%OAK RIDGE New Folder
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Create the remote Dakota Setup file

e Click inside the input editor window and use CTRL+SPACE key
sequence to display autocompletion options.

e Select the
Dakota
variant

%OAK RIDGE
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File Edit View Run Help

Reload Save Saveas Close tab Print
006 Navigation
Filter

dakota_remote.setup®

Cut Copy Paste

:l_e dako‘&a_remofe.seiup':r

#: NEAMS Workbench

Undo Redo Find

setup_properties
setup properties
setup_properties
setup_properties
setup_properties
setup_properties
setup_properties
setup_properties
setup_properties
setup_properties
setup_properties
setup_properties

Line: 1, Col: 1 v

pyarc : Input for remote setup

scale : Input for remote setup

ctffuel Input for remote setup

runctf : Input for remote setup

mcnp : Input for remote setup
hello_world : Input for remote setup
bison : Input for remote setup

sam : Input for remote setup
romulus.ornl.gov : Input for remote setup
panacea.ornl.gov : Input for remote setup
remus.ornl.gov : Input for remote setup
Input for remote setup

Processors y Setup_remote - Setup_remote 1 Setup_remote - Setup_remote 1 Run y
1|

/

setup_properties dakota : Input for remote setup

setup_properties nekdnuc Input for remote setup

Validation

Messages



Specity the remote Dakota Setup file parameters
1. Click Edit>Find to display the Find widget

2. Replace jdoe with your user id

| _NON 7 NEAMS Workbench
File Edit View Run Help
Reload Save Saveas Close  Print Cut Copy Paste Undo Redo Find
*
006 Nvigaton g son s [
Processors 5 Setup_remote - Setup_remote 1 . document .~ Setup_remote - Setup_remote 1
Filter 1 setup properties {
2
*
dakota_remote.setup 3 runtime command = "/home/jdoe/workbench/rte/entry.sh /home/jdoe/workbench/rte/dakota.py"
v document S e : ) .
t i 4 application path = "/projects/dakota/bin/dakota.sh
v se uP—F_’mpe 1es 5 hostname = "hpc.example.gov"
> runtlmeTcommand 6 username = "jdoe"
» application_path 7 remote execution home = "/home/jdoe"
» hostname 8 application name = "dakota remote" $% include the client and hostname to prevent collisions from other installation:
) username 9 upload patterns = ["${BASENAME}.drive" "*.tmpl" ] % using Python's glob syntax https://docs.python.org/2/library/q.
» remote_execution_home 10 download patterns = ["${BASENAME}*"] % using Python's glob syntax https://docs.python.org/2/library/glob.html
» application_name 11 tail file = "${BASENAME}.out"
» upload_patterns 12 version number = "1.0.0"
» download_patterns 13
p tail file 14 scheduler type = pbs
» version_number 15 scheduler_specs { ‘ .
» scheduler_type 16 submit path = "/usr/local/b}n/qsub §
» scheduler_specs 17 status_path = "/usr/local/bin/gstat
- 18 delete path = "/usr/local/bin/qgdel"
19 hold path = "/usr/local/bin/qhold"
20 release_path = "/usr/local/bin/qrls"
21 }
NN o ~abhAaAdss Tl A A A - r
Find: jdoe 4 > Case Sensitive X
%O AK Replace with: Replace | Replace & find | | Replace all
Natiotg Line: 8, Col: 77  /setup_properties/comment Validation ~ Messages




Specity the remote Dakota Setup file parameters
1. Replace workbench with your server-side NEAMS Workbench

installation

| NON )
File Edit View Run Help
Reload

Q0

Save Save as Close tab Print

Navigation

Filter

dakota_remote.setup*

v document

v setup_properties
runtime_command
application_path
hostname
username
remote_execution_home
application_name
upload_patterns
download_patterns
tail_file
version_number
scheduler_type
scheduler_specs

VVVVVVVVVYVYYY

%0AK

#:: NEAMS Workbench

Cut Paste Undo Redo Find

Copy

Processors Setup_remote - Setup_remote 1 document Setup_remote - Setup_remote 1
1 setup properties {
2
3 runtime command = "/home/jdoe/workbench/rte/entry.sh /home/jdoe/workbench/rte/dakota.py”
4 application path = "/projects/dakota/bin/dakota.sh"
5 hostname = "hpc.example.gov"
6 username = "jdoe"
7 remote execution home = "/home/jdoe"
8 application_name = "dakota_ remote" % include the client and hostname to prevent collisions from other installation:
9 upload patterns = ["${BASENAME}.drive" "*.tmpl" ] ¢ using Python's glob syntax https://docs.python.org/2/library/q.
10 download patterns = ["${BASENAME}*"] % using Python's glob syntax https://docs.python.org/2/library/glob.html
11 tail file = "${BASENAME}.out"
12 version number = "1.0.0"
13
14 scheduler type = pbs
15 scheduler specs {
16 submit path = "/usr/local/bin/gsub"
17 status_path = "/usr/local/bin/gstat"
18 delete path = "/usr/local/bin/qgdel"
19 hold path = "/usr/local/bin/qhold"
20 release_path = "/usr/local/bin/qrls"
21 }
ey o ~mbhAadssTl A A AdA - r
Find: workbench 4/ »  Case Sensitive %]
Replace with: ‘ Replace ‘ Replace & find ‘ Replace all ‘
Line: 3, Col: 44 o /setup_properties/runtime_command/value - Executable command for the runtime on the host Validation ~ Messages




Specity the remote Dakota Setup file parameters

1. Replace workbench with your server-side NEAMS Workbench
installation

2. Update the hosthname to be the server name on which the
NEAMS Workbench and application are installed

3. Review and update as nheeded the scheduler_specs
— Important for indicating scheduler queues or job runtime or memory

%OAK RIDGE
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Run the remote Dakota Setup file
e Click the run button to execute the Dakota setup file

[ NON ) s NEAMS Workbench
File Edit View Run Help
Reload Save Saveas Close  Print E Cut Copy Paste é Undo Redo E Find
0 06 Navigation
Processors y . Setup_remote - Setup_remote 1 - document - Setup_remote - Setup_remote 1 Runy
Filter : : —

setup_properties {

1
2
dakota_remote.setup 3 runtime command = "/home/rag/workbench/rte/entry.sh /home/rag/workbench/rte/dakota.py"
v document A =
5
(3

i application path = "/projects/dakota/bin/dakota.sh"
v setup_properties PP _p proj

l hostname = "hpc.example.gov"
» runtime_command nsername = "ragh
» application_path
» hostname
» username 28 Completed uploading to hpc.example.gov:/home/rag/workbench/rte/cirrus/packages/
» remote_execution_home 29
» application_name 30 Verifying expected transmission path on hpc.example.gov...
» upload_patterns 31
> dow;ﬂoad_patterns 32 Verified expected transmission path on hpc.example.gov: /home/raq/.cirrus/warroom7_hpc.example.gov/dakota remote server.j
» tail_file 33
» version_number 34 Removing existing application remote resources directory /projects/NEAMS/RELEASES/downloads/Workbench-Darwin/rte/remote :
» scheduler_type 35 Completed writing the class file at /projects/NEAMS/RELEASES/downloads/Workbench-Darwin/rte/dakota remote.py
> scheduler_specs 36 Reloading dakota_remote module...

37 Attempting to download the options file

38 Executing remotely '/home/rag/workbench/rte/entry.sh /home/rag/workbench/rte/dakota.py -json'

3E)

40 Completed downloading the options file at /projects/NEAMS/RELEASES/downloads/Workbench-Darwin/rte/remote resources/dakot:
41

42 Process finished with 0 return code; ran in 17 secs, finished at Mon Nov 18 14:15:19 2019

Line: 41, Col: 7  /setup_properties/comment Validation

%OAK RIDGE
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Configure the Dakota_remote application
 Click File>Configurations...

e Click Add... and select Dakota remote and click OK

O O == Application configurations
® OO0 s Application configurations
Moose E Remove
Application Environment Dakota_remote ﬁ Remove
Configuration ‘ . o Applications... line... _: Application Environment
Application Configuration: = Dakota_remote 1 a Addv Remove Rename...

Load Grammar

Select application to configure: S

Dakota_remote

Property Value
v Shared

Additional Arguments

Executable

Output Basename

Cancel

Run Environment

Variable Values

Variable Values Add

Unset

Apply
Apply

Cancel OK

National Laboratory




Configure the dakota_remote application

e Click Load Grammar, Apply, and OK. This enables Dakota input

creation.

e Nofe: Load grammar may
pause for a moment while
Workbench retrieves the
grammair files from the
server,

%OAK RIDGE
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@ w4t Application configurations

Dakota_remote Remove

E Add...

Application Environmen t

Configuration: Dakota_remote 1 u Addv Remove

Rename...

Application Options

Property Value
v Shared

Additional Arguments

Executable

Output Basename

Variable Values Add

Unset

Apply Cancel OK




Open the Dakota UQ Input

1.

%

Click File>Open... and navigate to and open the

Dakota/share/dakota/test/dakota_uq_users.in

select the
Dakota local
run configuration

OAK RIDGE
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File Edit View Run Help

Reload  Save

006

Saveas Close  Print

Navigation

Filter

v dakota_uq_users.in
v document
v environment
v tabular_data
tabular_data_file
v top_method_pointer
value
v method
v id_method
value
v sampling
sample_type
samples
seed
response_levels
distribution
v variables
v uniform_uncertain
value
lower_bounds
upper_bounds
descriptors
v interface
value
v analysis_drivers
value
fork
v asynchronous
evaluation_concurrency
v responses
v response_functions
value
no_gradients
no_hessians

= NEAMS Workbench

Cut Copy Paste | Undo Redo : Find
Processors y . Dakota - Dakota 1 [  document B
1 #@ s*: Label=FastTest
2 #@ s0: UserMan=textbook uq sampling
3 #@ s4: UserMan=textbook uq surrogate
4 # DAKOTA INPUT FILE - dakota uq users.in
5 # Dakota Input File: textbook uq sampling.in #s0
6 ## Dakota Input File: textbook uq surrogate.in #s4
7 environment
8 tabular_data
9 tabular_data_file = 'textbook_uqg_sampling.dat' #s0
10 # tabular data file = 'textbook uq surrogate.dat’ #s4
11 top _method pointer = 'UQ'
12
13 method
14 id_method = 'UQ'
15 sampling
16 sample_type lhs #s0,#s1,#s4
17 # sample type random #s2,#s3
18 samples = 10 #s50,#s2,#s3
19 # samples = 5 #s1
20 # samples = 1000 #s4
21 seed = 98765
22 response_levels = 0.1 0.2 0.6
23 0.1 0.2 0.6
24 0.1 0.2 0.6
25 distribution cumulative
26 # model pointer = 'SURR' #s4
27
28 #model #s4
29 # id model = 'SURR' #s4
30 # surrogate global #s4
31 # dace _method pointer = 'DACE’ #s4
32 # reuse points all #s4
33 ## polynomial quadratic #s4
34 #+# neural network #s4
35 ## gaussian process surfpack #s4
36 # mars #s4
37
38 #method #s4
39 # id method = 'DACE' #s4
40 # sampling sample type lhs #s4
41 # samples = 121 seed = 5034 #s4
42 # model nointer = "DACE M' #s4
Line: 7, Col: 9  /environment/decl Validaton ~ Messages




Run the Dakota UQ Input Locally
e Click the Run button to launch the job on the remote system

e Select the Messages button to display the messages panel

[ JON | s NEAMS Workbench

. File Edit View Run Help
[ WOI Or e ‘Reload Save Saveas Closetab  Print Cut Copy Paste Undo  Redo Find

° ‘o () Navigation 3 dakota_uq_u: n
JO b 'I'O Processors 5 Dakota - Dakota 1 . document | Dakota - Dakota 1 Run
Filier 1 #@ s*: Label=FastTest
. 2 #@ s0: UserMan=textbook uqg sampling
dakta_uQ_users'm 3 #@ s4: UserMan=textbook_ug_surrogate
v documen 4 # DAKOTA INPUT FILE - dakota ug users.in
v environment 5 # Dakota Input File: textbook uq sampling.in #s0
v tabular_data ) 6 ## Dakota Input File: textbook uq surrogate.in #s4
tabular_data_file [ Err—
v top_method_pointer 8 tabular data
value 9 tabular_data_file = 'textbook uq_sampling.dat' #s0
v method 10 # tabular data file = 'textbook uq surrogate.dat' #s4
v id_method 11 top_method_pointer = 'UQ'
value 12
v sampling 13 metl:hod
sample_type 14 1d_me&?hod = 'uQ’
samples 15 sampling
seed 16 sample_type lhs #50,#s1,#s4
17 # samnle tvobe random #52 . #s3
response_levels
distribution 3 Mon Nov 18
v variables 548
v uniform_uncertain 549 Partial Rank Correlation Matrix between input and output:
value 550 response_fn 1 response fn 2 response_ fn 3
lower_bounds 551 - - - - - -
upper_bounds 552 x1 -8.91349e-01 9.38667e-01 -8.33856e-01
descriptors 553
v interface 554 x2 -8.35713e-01 -7.16477e-01 9.33092e-01
v id_interface 555
value 556 — = — e U __
v analysis_drivers 557
value 558
fork 559 <<<<< Iterator random_ sampling completed.
v asynchrongus 560 <<<<< Environment execution completed.
evaluatlon_concurrency 561
v responses . 562 DAKOTA execution time in seconds:
v response_functlons 563
value 564 Total CPU = 0.017141 [parent = 0.017132, child = 9e-06]
no_gradients 565 Total wall clock =  0.044085
no_hessians 566
O R 567 Process finished with 0 return code; ran in 0 secs, finished at Mon Nov 18 15:53:22 2019
&National Laborato: Line: 7, Col: 9 y /environment/decl Validation
Ty v




Run the Dakota UQ Input Remotely
e Select the Dakota_remote run configuration

e Click the Run button to launch the job on the remote system
e Select the Messages button to display the messages panel
« Wait for the job fo complete

e Ensure the message panel states Successfully downloaded
dakota_uq_users.out

%OAK RIDGE
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Open associated output

« Right click the dakota_uq_users.in file and select Open
associated files> dakota_uq_users.out and review output

File Edit View Run Help

Reload  Save

Saveas Close  Print

Cut Copy Paste

s NEAMS Workbench

Undo Redo | Find

(x W) Navigation 3 dakota_uq_users.in
Processors y :  Dakota - Dakota 1 a - document
Filter 10 # tabular data file = 'textbook uq surrogate.dat’ #s4
- 11 top_method_pointer = 'UQ'

dakota_uq_users.in —

v document Reload %R

v environment Close BW o
v tabular_da :
tabular,_ Open directory 1hs #50, #s1,#s4

v top_methol I EETEACEES »

value Copy directory path to clipboard

method

value

v sampling
sample_type
samples
seed
response_levels
distribution

variables

v uniform_uncertain
value
lower_bounds
upper_bounds
descriptors

interface

v id_interface
value

v analysis_drivers
value
fork

v asynchronous

evaluation_concurrency

responses
v response_functions
value
no_gradients
no_hessians

rara Avaas A
. ¢ National Laboratory

Copy file path to clipboard
v id_method Create template
=

dakota_uq_users.err
dakota_uq_users.in.remote.out
dakota_uq_users.in_error.log

548
549 Partial Rank
550
551!
552 x1
553
554 x2
555

557
558
559 <<<<< Iterator random_sampling completed.
560 <<<<< Environment execution completed.

561
562 DAKOTA execution time in seconds:

563
564 Total CPU
565 Total wall
566

dakota_uq_users.in_hpc.example.gov.status.json
o0 response e dakota_uq_users.in_no_download_.json
23 - dakota_uq_users.in_output.log
24 dakota_uq_users.out
25 distribution
26 # model pointer = 'SURR' #s4

Correlation Matrix between input and output:
response_fn_1 response_fn_ 2 response_fn 3

-8.91349e-01 9.38667e-01 -8.33856e-01

-8.35713e-01 -7.16477e-01 9.33092e-01

= 0.017141 [parent =
clock = 0.044085

567 Process finished with 0 return code; ran in 0 secs,

Line: 7, Col: 9 y /environment/decl

0.017132, child =

finished at Mo

File Edit View Run Help

@ NEAMS Workbench

Reload Save Saveas Closetab  Print
Q @ Navigation
Filter
v dakota_uq_users.in
v document
v environment

v tabular_data
tabular_data_file

v top_method_pointer
value

method

v id_method
value

v sampling
sample_type
samples
seed
response_levels
distribution

variables

v uniform_uncertain
value
lower_bounds
upper_bounds
descriptors

interface

v id_interface
value

v analysis_drivers
value
fork

v asynchronous
evaluation_concurrency

responses

v response_functions
value

no_gradients
no_hessians

Cut Copy Paste : Undo Redo Find
3 dakota_uq_users.out

Processors -None- a a Run
1|Dakota version 6.8 released May 8 2018.

2 Repository revision 8a62837 (2018-05-07) built May 8 2018 01:34:22.
3 Running MPI Dakota executable in serial mode.

4 Start time: Mon Nov 18 15:53:22 2019

5

6

7 Begin DAKOTA input file

8 dakota_uqg_users.in

9
10 #@ s*: Label=FastTest
11 #@ s0: UserMan=textbook ug_sampling
12 #@ s4: UserMan=textbook_uqg_surrogate
13 # DAKOTA INPUT FILE - dakota_uq_users.in
14 # Dakota Input File: textbook ug_sampling.in #s0
15 ## Dakota Input File: textbook_uq_surrogate.in #s4
16 environment
17 tabular_data
18 tabular_data_file = 'textbook_uq_sampling.dat' #s0
19 # tabular_data_file = 'textbook_uq_surrogate.dat' #s4
20 top_method pointer = 'UQ'
21
22 method
23 id_method = 'UQ’'
24 sampling
25 sample_type lhs #s0,#s1, #s4
26 # sample_type random #s2,#s3
248 samples = 10 #s0, #s2, #s3
28 # samples = 5 #s1
29 # samples = 1000 #s4
30 seed = 98765
31 response_levels = 0.1 0.2 0.6
32 0.1 0.2 0.6
33 0.1 0.2 0.6
34 distribution cumulative
35 # model_pointer = 'SURR' #s4
36
37 #model #s4
38 # id_model = 'SURR' #s4
39 # surrogate global #s4
40 # dace_method _pointer 'DACE' #s4
41 # reuse_points all #s4
42 44 polvnomial anadratic #s4

Line: 1, Col: 1 Validation ~ Messages



Plot Correlation Matrices

e In the *.out editor view, select the correlation matrix to plot via
the Processors>Partial correlation matrix between input and

File Edit View Run Help

output =

#: NEAMS Workbench

Reload Save Saveas Closetab  Print
00 Navigation [x} 10. \_uq_users.Simple correlation matrix (allinputs and outputs).spf | <
) [ Piot  JREC
Filter

v dakota_uq_users.in
v document
v environment
v tabular_data
tabular_data_file

v top_method_pointer 352 response_fn 2 8.59620e-01 -3.35742e-01 -2.99322e-01 1.00000e+00 0.75
value 353 response_fn_3 -4.07188e-01 8.40792e-01 -1.18486e-01 -7.34022e-01 1.00000e+00
v method 354
v id_method 355 Partial Correlation Matrix between input and output: X2
“value 356 response_fn_1 response_fn 2 response fn_3 405
" x1 -8. e- . e-01 -9. e-
v samplin 357 1 -8.29267e-01 9.58139e-01 -9.30530e-01
ping 358 X2 -7.56720e-01 -8.49354e-01 9.76157e-01
sample_type
? 359 P
samples 360 Simple Rank Correlation Matrix among all inputs and outputs: E] 4025
seed 361 x1 x2 response_fn_1 response_fn_2 response_fn_3 1
response_levels 362 x1 1.00000e+00 O response_fn_1
~ distribution 363 x2 9.09091e-02 1.00000e+00 £
v variables 364 response_fn_1 -7.57576e-01 -6.12121e-01 1.00000e+00 a Jo
v uniform_uncertain 365 response_fn_2 8.78788e-01 -2.60606e-01 -4.54545e-01 1.00000e+00 =
value 366 response_fn_3 -4.18182e-01 8.0606le-01 -1.63636e-01 -6.12121e-01 1.00000e+00
lower_bounds 367
upper_bounds 368 Partial Rank Correlation Matrix between input and output: 0.25
descriptors 369 response_fn_1 response_fn_2 response_fn_3 response_fn_2
v interface 370 x1 -8.91349%e-01 9.38667e-01 -8.33856e-01
v id_interface gzé x2 -8.35713e-01 -7.16477e-01 9.33092e-01
value -05
o 373
v analysis_drivers 374
value 375 <<<<< Tterator random sampling completed. response_fn_3
fork 376 <<<<< Environment execution completed.
v asynchronous 377 DAKOTA execution time in seconds: response_in_1  response_in_2  response_fn_3
evaluation_concurrency 378 Total CPU = 0.017141 [parent = 0.017132, child = 9e-06] Inputs/Outputs
v responses 379 Total wall clock = 0.044085
v response_functions Line: 347, Col: 1 Validation ~ Messages
value
no_gradients ‘test/dakota_uq_users.Partial correlation matrix between input and output.spf I < /dakota_uq_users.Partial rank correlation matrix between input and output.spf I < » | ta_ug_users.Simple rank correlation matrix (all inputs and outputs).spf I <
no_hessians E— E— E—

dakota_uq_users.out
v dakota_uq_users.Partial correlation mat

N

Simple correlation matrix (all inputs and outputs)

tputs:
Simple rank correlation matrix (all inputs and.g

n_l response_fn_2 response_fn_3 |
X
350 000e+00
351 response_fn_1 -7.27631e-01 -5.96736e-01

1.00000e+00

Simple correlation matrix (all inputs and outputs)

ple correlation matrix

[Pt NPT

Table

Table

v~ document Partial correlation matrix between input and output Partial rank correlation matrix between input and output Simple rank correlation matrix (all inputs and outputs)
> title 1
» legend 0.9 0.9
> xlaxis Partial correlation matrix Partial rank correlation matrix Simple rank correlation matrix
» ylaxis 0.6 06 0.75
> x2axis . .
> y2axis X1 x2 05
» colormap 0.3 03
v dakota_uq_users.Partial rank correlatior ™ 0.25
» ~ document 'g 0 .
v dakota_uq_users.Simple correlation ma £ 0 response_fn_1
»  document 0
dakota_uq_users.Simple rank correlatio) -0.3
» |~ document X2 - 04 025
response_fn_2 g
-06
-06 -05
OAK RIDGE respon;e fmespon;e fneﬁpon;e na 08 response_fn_3
. T g n_; 0.75
National Laboratory Outputs response_in_2

response_fn_3

x2responseefipohseefpadse _fn_3




Summary

e You have successfully configured and run Dakota through the
NEAMS Workbench via a local and remote configuration
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Questions®e

« Email questions and issues to nwb-help@ornl.gov
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