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Assumptions

e The following slides assume

- the NEAMS Workbench has already been installed

« NEAMS Workbench is freely available from
https://code.ornl.gov/neams-workbench/downloads

e |Installaftion notes are at
https://code.ornl.gov/neams-workbench/downloads#install-neams-worklbench-

beta
- the ARC code suite has been installed
- PYyARC has been configured to use the ARC code suite

Need assistance<e Email nwb-help@ornl.gov
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https://code.ornl.gov/neams-workbench/downloads
https://code.ornl.gov/neams-workbench/downloads
mailto:nwb-help@ornl.gov

Client vs. Server definition

e ‘Server’, a.k.a. a ‘cluster’, is where compute resources are
available and jobs can be scheduled

e ‘Client’, a.k.a. a ‘local’ machine, is typically a laptop or
desktop with limited resource that can be used to Iocolly run
small jobs or submit jobs fo a remote server = .

[ ¢ Macintosh/Apple client

\\\\\\\\\\\\\\\

Linux client

Windows client

#,0AK RIDGE Typical Client-Server Topology
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Additional configurations

e Single-box — compute resource without a scheduler where jobs
are submitted across the network

ngngngngng

[ | |
AR
)

e Localhost — client is the
cluster head node with
scheduler from which jobs
are submitted locally
to the scheduler
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NEAMS Workbench Linux Server Installation

1. Download/copy the Workbench-Linux.zip to the server
— Secure copy from client to server — scp Workbench-Linux.zip server:

2. Unzip the deployment — unzip Workbench-Linux.zip
3. Untar the archive — tar -xf Workbench-Linux.tar.gz

4. Verity installation via the following

1. Execute Workbench-Linux/rte/entry.sh which should result in
Python tferminal with no import errors

2. Execute Workbench-Linux/bin/sonvalidjson which should resultin a
usage message (no library load errors)

Latest Linux distribution is available from https://code.ornl.gov/neams-workbench/downloads

NOTE: be sure to use the same client and server versions. Server installations can be shared between
users as long as the administrating user executes the Workbench-Linux/rte/entry.sh to configure the
necessary Python environment

%OAK RIDGE
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ARC Linux Server Installation

« Obtain the program executables and libraries from RSICC and Argonne National
Laboratory

o Configure installation intfo the following standard

arc/bin
arc/bin/lib

Where arc/bin contains the program executables
dif3d _gamsor.x
dif3d _to vtk.x
dif3d.x
ISOTXS _merge.x
mcc3.x
partisn.x
persent.x
rebus.Xx
twodant.x

If the executables are not already in this configuration one can use soft-links to properly
configure. E.g., In -s /path/to/dif3d dif3d.x
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Configure PYARC Linux Server Installation

* Create the NEAMS*-Linux/PyARC/.pyarc.rc file with the
following content

[exec]
path = /projects/arc/bin

e Ensure the path property lists the location previously configured
during the ARC Linux Server Installation step

%OAK RIDGE
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Local and Remote Application Sefup Overview

« Local application setup requires installation of the ARC code
suite on the same machine as is the NEAMS Workbench

« Remote application setup requirements
— Passwordless SSH* to remote Linux machine/cluster

— PBS-based cluster scheduler
« Remote application does support scheduler-less single-box
» Tested with Torgue/MAUI, IBM LSF, SLURM

— Initial setup step using the NEAMS Workbench SetupRemote
application*

- Remote Linux machine installation of the application and the NEAMS
Workbench

%.0AK RIDGE * See |later slide instructions
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New file... 3N

Run ConfigurOTiOns - O\/er\/iew New ORIGAMI Automator project.. (3N

Open file... #0
Open ORIGAMI Automator project... 4 3¥#0

« Application configurations are available under the Open ORIGEN concentation fe..

Open UNF-ST&DARDS time series...

File>Configurations... LT

Open continuous-energy library...
Open covariance library...
Open ORIGEN gamma data...

Recent files »

 Create application run configuration
~ Connects MOOSE-BISON, Dakota, ARC, etc. to the NEAMS Workbench o s

Save #S

* Allows creation of application variants/environments Sl o
] . Close FW
— Serial vs MPI, version 6.7 vs 6.8, etc. Close all oW
[ oK ) s Application configurations Print 3P
Moose [ Add.. Add Application Config . &
FoteatonEonmen
Configuration:  Bison1 [ Addv Remove Rename... Exit 8Q

Application Options /

Property Value ®  ® == Applications...

v Shared
Additional Argunfents - S o
Executable Ipath/to/bison-opt Select application to configure:

Output Basename

Output Diregtory IE)akota

Add or clone Application %E:::ch [
configuration environment :
" Allow Denrecated
Run Environment
Variable Values Add
Unset
%gﬁ)ﬁ%{gﬁg Apply Cancel  (OKI




Local Configuration of ARC suite via PyARC

1. Open the Application
Configuration dialog via
File>Configurations

@ 74+ Application configurations
2. SeleCT Add XX ArC Arc E Add... Remove
Application Environmen t

3 o U p d O -l-e -l-h e Exec Ulllq b I e Configuration: = Arc 1 E Addv Remove Rename... Load Grammar
property’s value to be

the absolute path to T

Additional Arguments

P A R C CI | |C O '|'| O n IEEEE I | Users/UID/Downloads/Workbench/PyARC/PyARC.py|
y p p Output Basename

script EaE——

Variable Values Add

Note: PYARC is deployed
with the Workbench at
Workbench/PyARC
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Remote Run Configuration of PYARC Overview
1. Configure passwordless SSH between the client and the server

2. Using the client install of the NEAMS Workbench, do the following:
a. Enable the NEAMS Workbench's Setup_Remote application
b. Create the application-server Setup_Remote input

c. Run application-server setup remote input 1o generate the NEAMS
Workbench PyARC remote run configuration.

d. Configure the PyARC_remote

e. Open any PYARC input and select the PyARC remote run configuration to
activate input validation, autocompletion, syntax highlighting and job
launch capabilities

f. Edit input as needed

g. Use the PYyARC remote run configuration to launch the PYARC input from
your client to the server

h. Wait for job to finish
i. Open files associated with the input file (*.out, summary, *.vik, etc.)

%OAK RIDGE
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Passwordless SSH Setup
« Required for remote run configurations

o Appends client machine’s authorized public key to the user’s
list of authorized keys residing on the server. The following
statement is sufficient to do so on Linux or Mac clients:

ssh server 'cat >> .ssh/authorized keys && chmod 644 .ssh/authorized keys' < ~/.ssh/id rsa.pub

« Replace ‘server’ with the name of target server. Test the
passwordless ssh by attempting to ssh o the server. You should
NoO longer observe the need to specify a password.

o Assumes server..ssh directory exists. If this does not exist,
run ssh-keygen on the server 1o generate the SSH directory.

« On Windows clients use the CMD console program to execute

type .ssh\id rsa.pub | ssh server "cat >> .ssh/authorized keys && chmod 644 .ssh/authorized keys"

%OAK RIDGE
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Start the client install of the NEAMS Worklbench

e Execute Workbench-<OS>/bin/Workbench

e Help documentation will display during the
first starfup

e Help documentation is accessible via
Help>Help Documentation

000 = NEAMS Workbench
File Edit View Run Help

Reload Save Saveas Close Print : Cut Copy Paste : Undo Redo Find

Q06 Navigation

m
5

[ JON | #s NEAMS Workbench
| File Edit View Run [HEIBI

chIoad Save Save as About opy Paste : Undo Redo Find

(x N ) Navig  Documents

Filter
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National Laboratory

© 00 [ newwsworsenchuserooc. x |+

C O Orie
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NEAMS Workbench User Documentation
Welcome to the NEAMS Workbench user documentation.
Youare here for two reasons

1. Use NEAMS Workbench to help you use an application, which are currenty
o SCALE Code System: comprehensive modeling and simulation suite for nuciear safety analysis
and design, https://www.omi goviscale
« CSAS: Critcality Safety
= MAVRIC: Radiation Shielding
« TRITON, POLARIS: Reactor Physics
= ORIGEN: Isotope concentration, activty, and radiation source term characterization
= XSProc: Cross Section Processing
= TSUNAMI: Sensitvity and Uncertainty

o ARC: Argonne Reactor Computation, https:/www.ne.anl.govicodes, and the PyARC interface
(RS Workbench Help <nwb-helplorad.gov:)
= MC2-3: Fast Reactor Cross Section Processing Codes
« DIF3D: Diffusion and Transport Theary Codes
= REBUS: Fuel Cycle/ Depletion
= PERSENT: Perturbation Theory Solver
= PYARC: Enhanced user inerface to the above

© MOOSE Applications - http://mooseframework.org/
= Bison: A Finite Element-Based Nuclear Fuel Performance Code, htps://bison.inl.gov/
« SAM: A Modem System Analysis Tool for Advanced Nuciear Reactors,
hitps/www.ne.anl.govicodes/sam/

o Dakota - UQ and Optimization toolkt, htps/dakota.sandia gov/
 Nek5000: High-order solver for i i

2. Integrate an application into NEAMS Workbench
o Read Application Integration section
© Clickthe nelp>pocusenta training Session’.pdf
o Contact yeas workbench Kelp <rwb-helphorni.govs

Getting Started with NEAMS Workbench and a supported Application
There are several steps to integrating a supported application into NEAMS Workbench.
1. Create an application runtime configuration via Configurations
2. Open or create an application input file

o May require the selection of the application's grammar, more of which can be leamed from the
Grammar Support section.

3. Edit, navigate, validate, execute, review.
now there is room for improvement, help us prioriize by providing feedback 1o xeas
Workbench Help <awb-helpfornl.gov>

Requirements

Supported Operating Systems
+ Linux 64-bit (RHELS)
+ Mac OS X (Darwin) 10.95 or newer
+ Windows 7,10 64-bit

For help compiing NEAMS Workbench from source please email xexs woskesch telp <owb-belptorad..gov>.

System Requirements

+ Minimum requirements: 2 GB RAM, dual core processor
« Recommended requirements: 4+ GB RAM, quad core processor
+ Recommended for details models: 16 GB RAM

Features

The NEAMS Workbench application consists of multiple components rendered as several panes in a GUI on
your terminal. Some of the primary components include:

+ Document Navigator - which allows quick navigation to input blocks

+ Input Editor - which features cursor context and automatic validation

+ Interactive Geometry Viewer - which includes a Vislt GUI control panel

« Data Plots - in either tabular or graphical format

An example NEAMS Workbench display s shown below:

08 mecrediastid_cute
Fna3itas

+ Setiings
o Environment
o Filter Set




Configure the Setup Remote Application

 Click File>Configurations...

[ NON | = NEAMS Workbench
JB8) Edit View Run Help
New file... . EN y Paste Undo Redo Find
- New ORIGAMI Automator project... TN ' '
ﬁ New Visualization...
Open file... #0

Open ORIGAMI Automator project...  {+30
Open ORIGEN concentration file...
Open UNF-ST&DARDS time series...

Open multigroup library...
Open continuous-energy library...
Open covariance library...

Open ORIGEN gamma data...

Recent files >
Recent ORIGAMI Automator projects

Reload #R
Save #S
Save as... O #S
Save all

Close #EW
Close all CEBW
Print BP
Settings... 3,

Reset settings

Exit ®8Q
%OAK RIDGE I
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Configure the Setup Remote Application

e Click Add... and select Setup_remote and click OK

® 0 = Application configurations

woose [} (D "o

Application Environme

Configuration:  Bis

ARDIcStion Options Moose Add... Remove
Propenrty
v Shared . g0 ;
Additions Application Environment
Executat
8u:pu:g Configuration:  Bison 1 Add v Remove Rename... Load Grammar
utpu
Save Wc L X
S Application Options
Run Environment Property O @ == Applications...
ar v Shared
e Additional Arguments Select application to configure:
Executable
Output Basename v Arc
Output Directory Ctffuel
Save Working Directo Dakota
Timactamn g ry Halite '
Hello_world r
Apply . 1 Nekdnuc )
Run Environment } Nek5000 F
T Variab Scale
ariable Btup_remote Add
iera
%OAK RIDGE Workbench Unset
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Configure the Setup Remote Application

e Click Load Grammar, Apply, and OK. This enables
SetupRemote input creation.

® 0 == Application configurations

Setup_ren Add... Remove

Application Environment

Configuration: = Setup_remote 1 B Add v Remove Rename... —

Application Options

Property Value
v Shared
Additional Arguments
Executable
Output Basename
Output Directory

Save Working Directory [

Timactamn

Run Environment

Variable Values Add

Unset

Apply Cancel OK
%OAK RIDGE
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Create the remote PYARC Setup file

e This connects the client/local NEAMS Workbench
to the remote NEAMS Workbench and PyARC
installation

O New file

Save As: pyarc_remote.setupl

Tags:

1. Click File>New file... (> sElm B Msewpsemo

2. Provide file name of
pyarc_remote.setup and
select Setup_remote as
the file type.

o Files of type: Setup_remote - Setup_remote 1 file... H
3. Click Save

New Folder

%OAK RIDGE
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Create the remote PYARC Setup file

e Click inside the input editor window and use CTRL+SPACE key
sequence to display autocompletion options.

[ NON | #a NEAMS Workbench
File Edit View Run Help

® S< 3|€ EC-I- Reload Save Saveas Closetab  Print Cut Copy Paste Undo Redo Find

PYARC 00 - e

Processors 5 | Setup_remote - Setup_remote 1 B B - Setup_remote - Setup_remote 1 B Aun y  View y  Edit 4

Filter

. 1|
1- ;
VO rIO n s - nekdnuc : Input for remote setup
5 - pyarc : Input for remote setup
se properties - scale : Input for remote setup
se _properties - hellec world : Input for remote setup
se properties - romulus.ornl.gov : Input for remote setup
setup properties - panacea.ornl.gov : Input for remote setup
setup properties - remus.ornl.gov : Input for remote setup
setup properties : Input for remote setup

%OAK RIDGE
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Specity the remote PyARC Setup file parameters
1. Click Edit>Find to display the Find widget

2. Replace jdoe with your user id

= NEAMS Workbench
File Edit View Run Help

Reload Save Saveas Closetab  Print Cut Copy Paste Undo Redo Find
o0 Navigaon g pyare remote o
Processors :  Setup_remote - Setup_remote 1 ‘41  document . Setup_remote - Setup_remote 1 K
Filter 1 setup_properties {
2
ya'setuP 3 runtime command = "/home/jdoe/workbench/rte/entry.sh /home/jdoe/workbench/rte/arc.py"
t i 4 application _path = "/home/jdoe/workbench/PyARC/PyARC.py"
M UP—PrOPe 1es 5 hostname = "hpc.example.gov"

D> runtl'me-_command 6 username = "jdoe"

» application_path 7 remote execution home = "/home/jdoe"

» hostname 8 application name = "pyarc remote" $ include the client and hostname to prevent collisions from other installat

> username 9 upload patterns = ["*.decay chain.son" "*.isotxs" "*.lumped.son"] % using Python's glob syntax https://docs.py

» remote_execution_home 10 download patterns = ["${BASENAME}*"] % using Python's glob syntax https://docs.python.org/2/library/glob.html

» application_name 11

» upload_patterns 12 version number = "1.0.0"

» download_patterns 13

» version_number 14 scheduler type = pbs

» scheduler_type 55 scheduler specs {

» scheduler_specs 16 submit path = "/usr/local/blln/qsub"
17 status _path = "/usr/local/bin/gstat"
18 delete path = "/usr/local/bin/gdel"
19 hold path = "/usr/local/bin/ghold"
20 release path = "/usr/local/bin/qrls"
21 }
Find: jdoe 4 > Case Sensitive $'4
Replace with: Replace || Replace & find | | Replace all

% Line: 1, Col: 1  /setup_properties/decl - Input for remote setup Validation =~ Messages




Specity the remote PyARC Setup file parameters

1. Replace workbench with your server-side NEAMS Workbench
installation

| _NON ) s NEAMS Workbench
File Edit View Run Help
Reload Save Saveas Closetab  Print Cut Copy Paste Undo Redo Find
o0 Navigation g pyare remote o
Processors y Setup_remote - Setup_remote 1 document E Setup_remote - Setup_remote 1
Filter 1 setup properties {
2
yare'setuP 3 Iruntime_command = "/home/jdoe/workbench/rte/entry.sh /home/jdoe/workbench/rte/arc.py"
ut i 4 application _path = "/home/jdoe/workbench/PyARC/PyARC.py"
M UP—PrOPe 1es 5 hostname = "hpc.example.gov"
D> runtl'me-_command 6 username = "jdoe"
» application_path 7 remote execution home = "/home/jdoe"
» hostname 8 application name = "pyarc remote" $ include the client and hostname to prevent collisions from other installat
> username 9 upload patterns = ["*.decay chain.son" "*.isotxs" "*.lumped.son"] % using Python's glob syntax https://docs.py
» remote_execution_home 10 download patterns = ["${BASENAME}*"] % using Python's glob syntax https://docs.python.org/2/library/glob.html
» application_name 11
» upload_patterns 12 version number = "1.0.0"
» download_patterns 13
» version_number 14 scheduler type = pbs
» scheduler_type 15 scheduler specs {
» scheduler_specs 16 submit path = "/usr/local/blln/qsub"
17 status _path = "/usr/local/bin/gstat"
18 delete path = "/usr/local/bin/gdel"
19 hold path = "/usr/local/bin/ghold"
20 release path = "/usr/local/bin/qrls"
21 }
Find: workbench 4 > Case Sensitive X
Replace with: Replace || Replace & find | | Replace all
OAK £
%National Line: 3, Col: 5  /setup_properties/runtime_command/decl - Executable command for the runtime on the host Validation =~ Messages




Specity the remote PyARC Setup file parameters

1. Replace workbench with your server-side NEAMS Workbench
installation

2. Update the hosthname to be the server name on which the
NEAMS Workbench and application are installed

3. Review and update as nheeded the scheduler_specs
— Important for indicating scheduler queues or job runtime or memory

%OAK RIDGE
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Run the remote PyARC Setup file
. CI|<:I< ‘the run button fo execute the PYARC setup file

#: NEAMS Workbench

Fllé Edlt View Run Help

Reload Save Saveas Close Print Cut Copy Paste Undo  Redo Find
Q06 Navigation I
Processors y . Setup_remote - Setup_remote 1 . document . Setup_remote - Setup_remote 1 Run
Filter 1 setup_properties {
2
v pyarc_remote.setup 3 runtime command = "/home/raqg/workbench/rte/entry.sh /home/raq/workbench/rte/arc.py"
v document ST o "
. 4 application path = "/home/raq/workbench/PyARC/PyARC.py

setqupemes 5 hostname = "hpc.example.gov"

» runtime_command

» application_path

» hostname

> username 24 Completed writi figuration file: /projects/NEAMS/RELEASES/downloads/Workbench-Darwin/rte/cirrus/packages/depl

» remote_execution_home ompleted writing server configuration file: /projects ownloads/Workbenc arwin/rte/cirrus/packages/deplc

» application_name 2

> upIoad_patTerns 26 Completed writing server Python script: /projects/NEAMS/RELEASES/downloads/Workbench-Darwin/rte/cirrus/packages/deployed/;
27

download_patterns
: version na?‘nber 28 Communicating via native ssh: /usr/bin/ssh
» scheduler_type :2”(9) No server specified. Unable to verify communication.
scheduler_specs

> —Sp 31 Attempting to upload to hpc.example.gov

32

33 Communicating via native ssh: /usr/bin/ssh

34 Verifying server credentials...

35

36 Verified server credentials are valid.

<7

38 Completed uploading to hpc.example.gov:/home/raqg/workbench/rte/cirrus/packages/

39

40 Verifying expected transmission path on hpc.example.gov...

41

42 Verified expected transmission path on hpc.example.gov: /home/raq/.cirrus/warroom7_hpc.example.gov/pyarc _remote server.py
43

44 Completed writing the class file at /projects/NEAMS/RELEASES/downloads/Workbench-Darwin/rte/pyarc remote.py

45 Loading pyarc_remote module..

46 Attempting to download the options file

47 Executing remotely '/home/raqg/workbench/rte/entry.sh /home/raq/workbench/rte/arc.py -json'

48

49 Completed downloading the options file at /projects/NEAMS/RELEASES/downloads/Workbench-Darwin/rte/remote resources/pyarcRe
50

51 Process finished with 0 return code; ran in 19 secs, finished at Fri Nov 15 14:31:04 2019

%OAK RID
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Configure the PyARC_remote application

 Click File>Configurations...

e Click Add... and select Pyarc_remote and click OK

voose [
Application Environment

Configuration: =~ Bison 1

Application Options

# Application configurations

Remove

Add v Remove Rename... Load Grammar

Property

v Shared
Additional Arguments
Executable
QOutput Basename
Output Directory
Save Working Directory

Timactamn

Run Environment

O @ == Applications...

~ Select application to configure:

Pyarc_remote -

Cancel

Variable

Apply

-

@ #s Application configurations

Pyarc_remote Remove

Application Environment
Configuration:  Pyarc_remote 1 a Add v Remove

Application Options

Rename...

Load Grammar

Property Value
v Shared
Additional Arguments
Executable
Output Basename
Output Directory
Save Working Directory

Timestamp
Verbose Level 0
Working Directory

v Unique

Run Environment

Variable Values

Apply

Add

Unset

Cancel OK

National Laboratory



Configure the PyARC_remote application

e Click Load Grammar, Apply, and OK. This enables PyARC iINput
creation. —_— T o e

Pyarc_remote E Add... Remove
Application Environmen t
¢ N O -l-e o I—O O d g rO m m O r m O y Configuration: Pyarc_remote 1 E Add v Remove Rename... m
pause for a moment while s oner
L3 Property Value
Workbench retrieves the .
° Executable
grammair files from the Quput Besenme
Save Working Directory
S e rV e r . Timestamp
Verbose Level 0
Working Directory
v Unique
Run Environmen t
Variable Values Add
Unset
%OAK RIDGE Apply Cancel OK
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Open the PYARC Sample_1 Input

e Click File>Open... and navigate to and open the
Workbench/PyARC/tutorial/Sample_1_MCC3_DIF3DFD

/Sample_1.son

» select the
Pyarc_remote
run configuration

%OAK RIDGE
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Reload  Save

006

File Edit View Run Help
Saveas Close Print

Navigation

Filter

v pyarc_remote.setup
» document
Sample_1.son
v document
v arc
v geometry
v materials
material - structure
material - fuel
material - coolant
material - bdc
v blends
blend - mix_ref
blend - mix_abs
blend - mix_hole
v surfaces
plane - z0
plane - z1
plane - z2
plane - z3
hexagon - hex_pin
hexagon - hex_outer
hexagon - hex_inner
cylinder - cyl_fuel
cylinder - cyl_clad
» reactor
v calculations
v mec3
num_cpu_max
xslib
egroupname
scattering_order
lumped_element_text |
cell-a
cell-b
cell-¢
cell -d
v dif3d
power
geometry_type
isotxs
max_axial_mesh_size
dif_fd_options

#u NEAMS Workbench

Run o

View

Edit

Copy Paste Undo Redo Find
€3 Sample_1.son

Processors y | Pyarc_remote - Pyarc_remote 1 ) | document ) | Pyarc_remote - Pyarc_remote 1
1 =arc

2 geometry{

3 materials{

4 material ( structure ) {

5 temp = 300 % temperature in Kelvin

6 adens{

7 aden ( fe56 ) = 5e-2 % atom density in atom/barn-cm
8 }

9 }
10 material ( fuel ) {
11 wdensity = 10 % weight density in g/cm”3
12 temp = 300 % temperature in Kelvin
13 aform( 2 ){ % atom count
14 afrac ( 016 ) =1 % atom fraction sum to one
15 }
16 aform( 1 ){ % atom count
17 afrac ( u235 ) = 0.17 % atom fraction sum to one
18 afrac ( u238 ) = 0.83 % atom fraction sum to one
19 }
20 }
21 material ( coolant ) {
22 temp = 300 % temperature in Kelvin
23 wdens {
24 wden ( na23 ) = 0.85 % weight density in g/cm”3
25 }
26 }
27 material ( bdc ) {
28 wdensity = 2.5 % weight density in g/cm”3
29 temp = 300 % temperature in Kelvin
30 aform( 4 ){ % atom count
31 afrac ( bl0 ) = 0.20 % atom fraction sum to one
32 afrac ( bll ) = 0.80 % atom fraction sum to one
33 }
34 aform( 1 ){ % atom count
35 afrac (¢ ) =1 % atom fraction sum to one

£ 1
Line: 2, Col: 5  /arc/g y/decl - [ ired] D 1 of the core model

Validation
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Run the PYARC Sample_1

INnput

e Click the Run button to launch the job on the remote system

e Select the Messa

« Wait for the
job to
complete

e0ce
File Edit View Run Help

Reload

006

Filte:

Save Saveas Closetab  Print

Navigation

v pyarc_remote.setup
» document
Sampl
v document

v arc
v geometry

v materials
material - structure
material - fuel
material - coolant
material - bdc

v blends
blend - mix_ref
blend - mix_abs
blend - mix_hole

v surfaces
plane - z0
plane - z1
plane - z2
plane - z3
hexagon - hex_pin
hexagon - hex_outer

« Ensure the outpu
states Successfull

ow n I o q d e d coindor- oy el

Sample_1.dif3d.v

num_cpu_max
xslib

egroupname
scattering_order
lumped_element_text_

cell-a

cell-b

cell-c

cell -d
v dif3d

power
geometry_type

isotxs
max_axial_mesh_size
dif_fd_options

%OAK RIDGE
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ges button to display the messages panel

#= NEAMS Workbench

Cut Copy Paste : Undo Redo : Find
€3 Sample_1.son
Procossors': Pyarc_remote - Pyarc_remote 1 a document E Pyarc_remote - Pyarc_remote 1 E Run y View y  Edit
1 =arc
2 geometry{
3 materials{
4 material ( structure ) {
5 temp = 300 % temperature in Kelvin
6 adens{
7 aden ( fe56 ) = 5e-2 % atom density in atom/barn-cm
8 }
9 }
10 material ( fuel ) {
11 wdensity = 10 % weight density in g/cm”3
12 temp = 300 % temperature in Kelvin
13 aform( 2 ){ % atom count

€3 Wed May 15 10:08:25 2019

1 args for remote capability: -i /projects/PyARC/repo/test/Tutorial/Sample 1 MCC3_DIF3DFD/Sample_l.son -remote_sleep_seconds 5 -remote_ autoc_download
3 Command line arguments identified for the target runtime are:
4 Received input /projects/PyARC/repo/test/Tutorial/Sample_ 1
5 Setting outp: /projects/PyARC/repo/test/Tutorial/Sample 1
6 Python version
7 Python executable:

D/Sample_l.son
D/Sample l.son.remote.out

MCC3_DIF3

ile
2.7.1
/projects/workbench/build/debug/INSTALL/rte/conda/bin/python

8
9 Client is requesting the server's base directory...
10 Sending command: /home/raq/NEAMS+VisIt-rev3al33952a-Linux/rte/entry.sh /home/rag/.cirrus/CTZPOPHO/pyarc_remote_ server.py --base dir

11 Client is copying files to
12 sending command: /home/rag/
13 840

14 Transmitted to

he server's base directory /home/rag/
S+VisIt-rev3al33952a-Linux/rte/entry.sh /home/rag/.cirrus/CTZPOPHO/pyarc remote server.py --submit=/home/raq//projects/PyARC/repo/te

server hpc.example.gov with job ID 840

15
16 Storing : /projects/PyARC/repo/test/Tutorial/Sample_ 1 MCC3 DIF3DFD/Sample l.son_hpc.example.gov.status.json
17 Calling i /orojects/workbench/build/debug/INSTALL/rte/conda/bin/python /projects/workbench/build/debug/INSTALL/rte/cirrus/packa
18
19 Job 840 is queued with scheduler: 20190515 100843
20
21 Job 840 is started: 20190515 100844
22
23 .
24
25 Job 840 is done: 20190515 100914
26
27 Job B840 return code: 0
28
Line: 8, Col: 20 y /arclt v/ ials/ - Isotopic defined as atom densities |




Run Configurations

 The Run Configuration is what communicates the application’s
grammar fo the NEAMS Worklbench

- The grammar is the definition of how to interpret the input syntax, data,
efc.

e Note: If you open an application input and there is no
grammar available (no input navigation tree), check that your
application’s run configuration is setup.
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Questions®e

« Email questions and issues to nwb-help@ornl.gov

%OAK RIDGE

National Laboratory



mailto:nwb-help@ornl.gov

