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Presentation Overview
• NEAMS Workbench Installation

• Required ORNL Accounts

• SSH configuration

• NEAMS Workbench SetupRemote configuration of remote 
SCALE

If any issues arise during these instructions, please contact the 
NEAMS Workbench help line - nwb-help@ornl.gov - for 
assistance.

mailto:nwb-help@ornl.gov
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NEAMS Workbench Installation

1. Download the latest version from 
https://code.ornl.gov/neams-workbench/downloads for your 
operating system

2. Unzip the software bundle

3. The NEAMS Workbench is now installed
– An additional Python environment installation will occur upon the first 

execution of the NEAMS Workbench

https://code.ornl.gov/neams-workbench/downloads


4

Remote Application Setup Requirements

• ORNL UCAMS credentials, login1 and compute resource 
accounts

• SSH Port forwarding*
– This will need to be active for all transactions with compute resources

• Passwordless SSH* to remote Linux machine/cluster*

• A compute resource installation of the NEAMS Workbench
– This is ORNL provided, but useful to know if configuring your own install

• A NEAMS Workbench SetupRemote* configuration for remote 
SCALE on ORNL computer resources 

* See later slide instructions
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Requires ORNL Accounts

• Work with your ORNL host to obtain:
– UCAMS account 

• enables ORNL network access
• You should receive in the mail a RSA SecurId security token for network access

– Login1.ornl.gov account 
• enables SSH via login1 jump server into ORNL network

– Compute resource account 
• Enables job submission
• Please review compute resource user guidance and policies

Note: Be sure to take and keep current your ORNL Cyber security training or your accounts 
will be suspended
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SSH Port forwarding

• Requires an SSH client installed
– Windows can use OpenSSH – included with Windows 10 as of 2018 and 

later.

• Requires SSH private-public key pair

• Requires SSH port forward configuration
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Open CMD

The follow slides and included instructions
will use the CMD program. Use the 
Start/Windows search to open the 
program

1. Press the Windows key or click the 
Windows icon and type ‘CMD’ to 
search. 

2. Press ENTER or left click the Command 
Prompt icon
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SSH Client
• Ensure SSH client is available

– Open CMD program and enter where ssh
– If SSH is available, the path to the program will be printed in the 

console

If no SSH client is available, please contact nwb-help@ornl.gov

mailto:nwb-help@ornl.gov
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Generate SSH private-public key pairs
• With CMD open, run ssh-keygen
• Accept all the defaults (hit enter 3 times)

– Do not enter a passphrase – this will require additional authentication 
which will prevent the NEAMS Workbench from operating as expected
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SSH Port Forwarding - Login1.ornl.gov

host tunnelinit
Hostname login1.ornl.gov
User UCAMS-ID
LocalForward XXXXX remus.ornl.gov:22
LocalForward YYYYY romulus.ornl.gov:22

Host remus_via_tunnel
HostKeyAlias remus.ornl.gov
Hostname localhost
Port XXXXX
User UCAMS-ID

Host romulus_via_tunnel
HostKeyAlias romulus.ornl.gov
Hostname localhost
Port YYYYY
User UCAMS-ID

SSH tunnel config Steps:
1. Open a new file called ‘config’ in the HOME/.ssh directory
2. Copy the text from box on right into the ‘config’ file
3. Update UCAMS-ID to be your ORNL-provided user id
4. Update XXXXX to be a port number between 10000 and 55555

• This must be unique across users.
5. Update YYYYY to be a port number between 10000 and 55555

• This must be unique across users.

TEXT TO COPY INTO CONFIG FILE
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SSH Port Forward check
• Ensure HOME\.ssh\config file exists

– e.g., did you create HOME\.ssh\config.txt by accident?
Move/rename it to HOME\.ssh\config

• HOME\.ssh\config should look like:
– BE SURE TO USE DIFFERENT USER and 

PORT NUMBERS

host tunnelinit
Hostname login1.ornl.gov
User raq
LocalForward 12345 remus.ornl.gov:22
LocalForward 54321 romulus.ornl.gov:22

Host remus_via_tunnel
HostKeyAlias remus.ornl.gov
Hostname localhost
Port 12345
User raq

Host romulus_via_tunnel
HostKeyAlias romulus.ornl.gov
Hostname localhost
Port 54321
User raq

EXA
M

PLE HO
M

E\.ssh\config
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Initialize SSH tunnel

1. Open a CMD windows

2. Activate the tunnel by performing ‘ssh tunnelinit’

3. If the ‘authenticity of host login1.ornl.gov’ can’t be 
established, response ‘yes’ to proceed

4. Enter your ORNL pin and the 
RSA SecurID token number 

5. Observe the login1.ornl.gov 
user notice and active 
prompt indicating success
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Compute Resource Access via login1
1. From a new CMD windows enter ssh remus_via_tunnel
2. If the ‘authenticity of host remus.ornl.gov’ can’t be 

established, response ‘yes’ to proceed

3. Enter your UCAMS password 
when prompted

4. Observe the user notice 
and remus prompt 
indicating success

Note: the ssh tunnel must be
initialized prior to this or future 
compute resource transactions
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Activate Port Forwarding

1. Open a Terminal
– Windows provides CMD as a terminal

2. Activate the tunnel by performing ‘ssh tunnelinit’

3. Enter ORNL pin and the RSA token number 
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Perform SSH to remote resource through tunnel
• Open a new terminal

– Make sure the tunnel is active from previous slide’s instructions
– Windows provides CMD as a terminal

• SSH to remus_via_tunnel
– ssh remus_via_tunnel
– Enter UCAMS password

• Observe you are logged into the remote resource 
(remus.ornl.gov) from outside the ORNL network via the active 
tunnel. 
– Remember, the tunnel must be active for any SSH to remote resource 

to function.
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Passwordless SSH Setup
• Required for remote SCALE configurations to operate

• Appends client machine’s public key to the user’s list of 
authorized keys residing on the server. 

For Windows clients the following statement executed in your 
home directory from a CMD terminal is sufficient to configure 
passwordless ssh to the computer resource:
type .ssh\id_rsa.pub | ssh remus_via_tunnel "cat >> .ssh/authorized_keys && chmod 644 .ssh/authorized_keys"

Note: The SSH tunnel must be active for these commands to function. 
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Passwordless SSH Setup Check
1. Conduct the command to append your public SSH key to 

your server account’s list of authorized keys 

2. When prompted enter your UCAMS password
3. Test the passwordless SSH by running ssh remus_via_tunnel
4. Observe no 

password is 
requested, the 
user notice and 
the remus
prompt 
indicating 
success
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Start the client install of the NEAMS Workbench
• Execute Workbench-

Windows\bin\Workbench
• Help documentation will display during the 

first startup

• Help documentation is accessible via 
Help>Help Documentation
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Remote Run Configuration Overview
1. Enable the NEAMS Workbench’s Setup_Remote application
2. Create the application-server Setup_Remote input
3. Run application-server SCALE remote input to generate the NEAMS 

Workbench SCALE remote run configuration.
4. Configure the SCALE remote
5. Open any SCALE input and select the SCALE remote run configuration 

to activate input validation, autocompletion, syntax highlighting and job 
launch capabilities

6. Edit input as needed
7. Use the SCALE remote run configuration to launch the SCALE input from 

your client to the server
8. Wait for job to finish
9. Open files associated with the input file (*.out, *.msg, *.3dmap, etc.)
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Configure the Setup Remote Application
• Click File>Configurations…
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Configure the Setup Remote Application
• Click Add… and select Setup_remote and click OK
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Configure the Setup Remote Application

• Click Load Grammar, Apply, and OK. This enables 
SetupRemote input creation.
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Create the remote SCALE Setup file

1. Click File>New file…
2. Provide file name of 

scale_remus.setup and 
select Setup_remote as 
the file type.

3. Click Save

• This connects the local NEAMS Workbench to the 
remote NEAMS Workbench and application 
installation

scale_remote.setup
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Create the remote SCALE Setup file
Enter the following content and replace UID with your UCAMS id.
setup_properties {

runtime_command = "/home/raq/workbench/rte/entry.sh /home/raq/workbench/rte/scale.py"
application_path = "/scale/scale_dev/mpi/bin/scalerte"
hostname = "remus_via_tunnel"
username = "UID"
remote_execution_home = "/home/UID"
application_name = "scale_remus_n16" 
upload_patterns = []
download_patterns = ["${BASENAME}.*"] 
follow_pattern = "${BASENAME}.msg"

version_number = "1.0.0"

scheduler_type = pbs
scheduler_specs {

submit_path = "/usr/local/bin/qsub"
status_path = "/usr/local/bin/qstat"
delete_path = "/usr/local/bin/qdel"
hold_path = "/usr/local/bin/qhold"
release_path = "/usr/local/bin/qrls"

}

scheduler_header [
"#PBS -l nodes=1:ppn=16"
"module load toolchain/gcc/4.8.3"

]
communication_type = ssh

}
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1. application_path – the server’s SCALE installation location –
1. Beta installs - /scale/release/6.3b#/linux/bin/scalerte, /scale/release/6.3b#/linux-

mpi/bin/scalerte
2. Production installs - /scale/release/6.2.#/linux/INSTALL/bin/scalerte, 

/scale/release/6.2.#/linux-mpi/INSTALL/bin/scalerte
3. Latest development - /scale/scale_dev/serial/bin/scalerte, 

/scale/scale_dev/mpi/bin/scalerte

2. Hostname – the compute resource that will host the compute job. E.g., 
remus_via_tunnel, romulus_via_tunnel

3. application_name – the name of the generated remote configuration. 
Best practice dictates this be a combination of application, hostname, 
and parallelism – e.g., scale_remus_n16 

4. scheduler_specs - Important for indicating scheduler queues, job 
runtime, parallelism and memory, and compiler modules

1. #PBS -l nodes=1:ppn=16 # PBS scheduler instructions to run the job on 1 node using 
16 processors per node

2. module load toolchain/gcc/4.8.3

Remote SCALE Setup parameter review
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Run the remote SCALE Setup file
• Click the run button to execute the SCALE setup file

– Ensure the setup_remote run configuration is selected, adjacent to the 
run button
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Configure the SCALE remote application
• Click File>Configurations…
• Click Add… and select scale_remus_n16 and click OK
• In the Application Options panel update the Number of 

Processes value to 16
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Configure the SCALE remote application

• Click Load Grammar, Apply, and OK. This enables SCALE input 
creation.

• Runtime Environment allows assign of alternate DATA, TMPDIR
– Remove if not desired

• Note: Load grammar may
pause for a moment while
Workbench retrieves the 
grammar files from the 
server.
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Run Configurations

• The Run Configuration is what communicates SCALE’s grammar 
to the NEAMS Workbench
– The grammar is the definition of how to interpret the input syntax, data, 

color and verify input.

• Note: If you open an application input and there is no 
grammar available (no input navigation tree), check that your 
application’s run configuration is setup. 
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Test the remote configuration – open the sample problem
• Open the provided mavric-shift.aos100.inp sample problem

– Note the SCALE grammar is automatically selected 



31

Test the remote configuration – run the sample problem
• With the scale_remus_n16 run configuration selected, adjacent 

to the run button, run the sample problem by click the run
button

• Notice the Messages panel
button (lower right corner)
highlight in red. Select this to
display the execution log.

• Notice the log shows the
Job transmits, queues, 
starts, statuses, completes, 
and results are
downloaded to your 
machine



32

Test the remote configuration – examine results
• To examine associated files, right click the input file and select 

Open associated files
• Select mavric-shift.aos100.out
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Summary
• You have performed the following:

1. Configured SSH Tunnel into the ORNL Network using your UCAMS 
credentials

2. Configured Passwordless SSH into ORNL compute resources
3. Configured the NEAMS Workbench to execute parallel (16 processes) 

SCALE jobs on ORNL compute resources
• For serial execution repeat slides 24 (Create the remote SCALE Setup file) through 

28 (Configure the SCALE remote application) with the following substitutions
1. Slide 25 - Update ‘scale_remus_n16' to be 'scale_remus' and delete "#PBS -l 

nodes=1:ppn=16" from the scheduler_header
2. Slides 25-28 use/select ‘scale_remus’ instead of ‘scale_remus_n16’ 
3. Slide 27 – do not specify the Number of Processes (leave as default of 1)
Note : Some input parameters are only available during parallel execution (Mavric-Shift 
x/yblocks). These will need to be removed/commented out when executed in serial. 
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Questions

• Please email nwb-help@ornl.gov with questions, issues, 
concerns 

mailto:nwb-help@ornl.gov

