Unverified Commit effbf629 authored by Daniel Holbach's avatar Daniel Holbach Committed by GitHub
Browse files

Merge pull request #428 from weaveworks/k8s-1.21

Updated Kubernetes to 1.21
parents acef34e9 6423bf00
......@@ -2,12 +2,12 @@ kind: Cluster
apiVersion: kind.x-k8s.io/v1alpha4
nodes:
- role: control-plane
image: "kindest/node:v1.20.2"
image: "kindest/node:v1.20.7"
- role: control-plane
image: "kindest/node:v1.20.2"
image: "kindest/node:v1.20.7"
- role: control-plane
image: "kindest/node:v1.20.2"
image: "kindest/node:v1.20.7"
- role: worker
image: "kindest/node:v1.20.2"
image: "kindest/node:v1.20.7"
- role: worker
image: "kindest/node:v1.20.2"
image: "kindest/node:v1.20.7"
......@@ -2,12 +2,12 @@ kind: Cluster
apiVersion: kind.x-k8s.io/v1alpha4
nodes:
- role: control-plane
image: kindest/node:v1.21.1
image: kindest/node:v1.21.2
- role: control-plane
image: kindest/node:v1.21.1
image: kindest/node:v1.21.2
- role: control-plane
image: kindest/node:v1.21.1
image: kindest/node:v1.21.2
- role: worker
image: kindest/node:v1.21.1
image: kindest/node:v1.21.2
- role: worker
image: kindest/node:v1.21.1
image: kindest/node:v1.21.2
......@@ -2,12 +2,12 @@ kind: Cluster
apiVersion: kind.x-k8s.io/v1alpha4
nodes:
- role: control-plane
image: kindest/node:v1.19.7
image: kindest/node:v1.22.0
- role: control-plane
image: kindest/node:v1.19.7
image: kindest/node:v1.22.0
- role: control-plane
image: kindest/node:v1.19.7
image: kindest/node:v1.22.0
- role: worker
image: kindest/node:v1.19.7
image: kindest/node:v1.22.0
- role: worker
image: kindest/node:v1.19.7
image: kindest/node:v1.22.0
......@@ -97,9 +97,9 @@ jobs:
fail-fast: false
matrix:
kubernetes:
- "1.19"
- "1.20"
- "1.21"
- "1.22"
steps:
- uses: actions/checkout@v2
- name: Find go version
......
......@@ -74,9 +74,9 @@ jobs:
strategy:
matrix:
kubernetes:
- "1.19"
- "1.20"
- "1.21"
- "1.22"
steps:
- uses: actions/checkout@v2
- name: Find go version
......
......@@ -48,7 +48,7 @@ server:
| kured | kubectl | k8s.io/client-go | k8s.io/apimachinery | expected kubernetes compatibility |
|-------|---------|------------------|---------------------|-----------------------------------|
| main | 1.20.5 | v0.20.5 | v0.20.5 | 1.19.x, 1.20.x, 1.21.x |
| main | 1.21.4 | v0.21.4 | v0.21.4 | 1.20.x, 1.21.x, 1.22.x |
| 1.7.0 | 1.20.5 | v0.20.5 | v0.20.5 | 1.19.x, 1.20.x, 1.21.x |
| 1.6.1 | 1.19.4 | v0.19.4 | v0.19.4 | 1.18.x, 1.19.x, 1.20.x |
| 1.5.1 | 1.18.8 | v0.18.8 | v0.18.8 | 1.17.x, 1.18.x, 1.19.x |
......
module github.com/weaveworks/kured
go 1.15
go 1.16
require (
github.com/containrrr/shoutrrr v0.5.1
......@@ -10,10 +10,9 @@ require (
github.com/sirupsen/logrus v1.8.1
github.com/spf13/cobra v1.2.1
github.com/stretchr/testify v1.7.0
golang.org/x/crypto v0.0.0-20210506145944-38f3c27a63bf // indirect
gotest.tools/v3 v3.0.3
k8s.io/api v0.20.5
k8s.io/apimachinery v0.20.5
k8s.io/client-go v0.20.5
k8s.io/kubectl v0.20.5
k8s.io/api v0.21.4
k8s.io/apimachinery v0.21.4
k8s.io/client-go v0.21.4
k8s.io/kubectl v0.21.4
)
This diff is collapsed.
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment